arrow-left arrow-right autosave chat checkmark close dashboard fields fingerprint flash hamburger language list lock logotype long-arrow-right marker migrate overviews phone rocket search smiley stamp star stopwatch team twitter

Please read carefully and check if the version of your Zammad system is affected by this vulnerability. Please send information regarding vulnerabilities in Zammad to: security at zammad.com

Security Advisory Details

Vulnerability Descriptions

Persistent Cross-Site Scripting - Email (XSS) (CVE 2020-10098)

Malicious code can be provided by a low-privileged user through the Email functionality in Zammad. The malicious JavaScript will execute within the browser of any user who opens the Ticket with the Article created from that Email.

Special 🙏 and 🤘 and ❤️ to:

N: Christopher Friedrichs
D: Security Researcher
W: https://www.qwertiko.de

Recommended Resolution

This vulnerability is fixed in the latest versions of Zammad and it is recommended to upgrade to one of these.

Fixed releases can be found at:

Or just update your Zammad if installed via OS package manager.

Additional information

Online version of this advisory: https://zammad.com/news/security-advisory-zaa-2020-03

Send all remarks to security issues to security @ zammad.com.