Security Advisory

ZAA-2022-11

· Please read carefully and check if the version of your Zammad system is affected by this vulnerability. Please send us information regarding vulnerabilities in Zammad!

Security Advisory Details

  • ID: ZAA-2022-11
  • Date: 2022-12-21
  • Title: Multiple Vulnerabilities
  • Severity: critical
  • Product: Zammad 5.3.x
  • Fixed in: Zammad 5.3.1
  • References:
    --> pending CVE assignment

Vulnerability Descriptions

Multiple Vulnerabilities

The Zammad front end can communicate with the server bi-directionally through a web socket connection or via AJAX. An attacker could send a specially crafted message to the server, causing this message to be sent to all active front ends, which would then react to the payload. This would enable the attacker to abuse their session to perform malicious changes in their front end (Remote Code Execution) and (with their permission set) also on the server (Privilege Escalation).

Special 🙏 and 🤘 and ❤️ to:

Recommended Resolution

This vulnerability is fixed in the latest versions of Zammad and it is recommended to upgrade to one of these.

Fixed releases can be found at:

Or just update your Zammad if installed via OS package manager.

Additional information

Online version of this advisory: https://zammad.com/en/advisories/zaa-2022-11

Please send remarks on security issues exclusively to security@zammad.com.

Signup
Freuen Ihre Kunden sich schon auf die Service-Hotline?
Kostenlos testen!
Newsletter
Alle Neuigkeiten direkt in Ihrer Inbox!
Zum Newsletter anmelden