Security Advisory

ZAA-2024-04

· Please read carefully and check if the version of your Zammad system is affected by this vulnerability. Please send us information regarding vulnerabilities in Zammad!

Security Advisory Details

  • ID: ZAA-2024-04
  • Date: 2024-05-15
  • Title: Local Code Injection
  • Severity: high
  • Product: Zammad 6.3.x
  • Fixed in: Zammad 6.3.1
  • References:
    --> pending CVE assignment

Vulnerability Descriptions

Local Code Injection

A Ruby gem bundled by Zammad installed with world writable file permissions. This allowed a local attacker on the server to modify these files, injecting arbitrary code into the Zammad processes which runs with the environment and permissions of the Zammad user.

Special 🙏 and 🤘 and ❤️ to:

This vulnerability is fixed in the latest versions of Zammad and it is recommended to upgrade to one of these.

Fixed releases can be found at:

Or just update your Zammad if installed via OS package manager.

Additional information

Online version of this advisory: https://zammad.com/en/advisories/zaa-2024-04

Please send remarks on security issues exclusively to security@zammad.com.

Signup
Freuen Ihre Kunden sich schon auf die Service-Hotline?
Kostenlos testen!
Newsletter
Alle Neuigkeiten direkt in Ihrer Inbox!
Zum Newsletter anmelden