Security Advisory

ZAA-2020-21

· Please read carefully and check if the version of your Zammad system is affected by this vulnerability. Please send us information regarding vulnerabilities in Zammad!

Security Advisory Details

  • ID: ZAA-2020-21
  • Date: 09/22/2020
  • Title: Stored XSS in Tags element
  • Severity: medium
  • Product: Zammad 1.0.x up to 3.4.0
  • Fixed in: Zammad 3.4.1, 3.5.0
  • References:
    --> CVE: Pending

Vulnerability Descriptions

Stored XSS in Tags element

Zammad comes with a functionality to add Tags to Tickets. Added Tags are shown to the Agent in the Ticket view. However, when rendering the Tags no proper quoting is in place so the raw text is added to the DOM and rendered. This allows an attacker to store malicious code to a Ticket that will be evaluated when opening a Ticket.

Special 🙏 and 🤘 and ❤️ to:

Recommended Resolution

This vulnerability is fixed in the latest versions of Zammad and it is recommended to upgrade to one of these.

Fixed releases can be found at:

Additional information

Online version of this advisory: https://zammad.com/en/advisories/zaa-2020-21

Send all remarks to security issues to security@zammad.com.

Signup
Freuen Ihre Kunden sich schon auf die Service-Hotline?
Kostenlos testen!
Newsletter
Alle Neuigkeiten direkt in Ihrer Inbox!
Zum Newsletter anmelden