Security Advisory

ZAA-2020-22

· Please read carefully and check if the version of your Zammad system is affected by this vulnerability. Please send us information regarding vulnerabilities in Zammad!

Security Advisory Details

  • ID: ZAA-2020-22
  • Date: 11/16/2020
  • Title: Potential Information Disclosure caused by default signup roles
  • Severity: low
  • Product: Zammad 1.0.x up to 3.5.0
  • Fixed in: Zammad 3.5.1, 3.6.0
  • References:
    --> CVE: 2020-29159

Vulnerability Descriptions

Potential Information Disclosure caused by default signup roles

Zammad comes with a functionality to add define custom Roles a newly created User gets assigned automatically e.g. by sending an email or manually creating an account. It was possible for an Administrator to assign privileged Roles for newly created Users allowing them to access restricted parts of Zammad resulting in a potential Information Disclosure.

Recommended Resolution

This vulnerability is fixed in the latest versions of Zammad and it is recommended to upgrade to one of these.

Note

Per default the following permissions can now be used for a "default_at_signup" role: 'user_preferences', 'user_preferences.password', 'user_preferences.notifications', 'user_preferences.access_token',
'user_preferences.language', 'user_preferences.linked_accounts', 'user_preferences.device', 'user_preferences.avatar', 'user_preferences.calendar', 'user_preferences.out_of_office' and 'ticket.customer'.

Fixed releases can be found at:

Additional information

Online version of this advisory: https://zammad.com/en/advisories/zaa-2020-22

Send all remarks to security issues to security@zammad.com.

Signup
Freuen Ihre Kunden sich schon auf die Service-Hotline?
Kostenlos testen!
Newsletter
Alle Neuigkeiten direkt in Ihrer Inbox!
Zum Newsletter anmelden