Security Advisory

ZAA-2021-16

· Please read carefully and check if the version of your Zammad system is affected by this vulnerability. Please send us information regarding vulnerabilities in Zammad!

Security Advisory Details

  • ID: ZAA-2021-16
  • Date: 10/05/2020
  • Title: Stored XSS in article attachments
  • Severity: high
  • Product: Zammad 1.0.x up to 4.1.0
  • Fixed in: Zammad 4.1.1, 5.0.0
  • References:
    --> CVE: CVE-2021-42092

Vulnerability Descriptions

Stored XSS in article attachments

Zammad comes with the functionality to upload attachments to Tickets via Articles. These attachments may include malicious JavaScript code that gets blocked by a Content-Security-Policy. However, there is the possibility to upload attachments that won't get blocked by the Content-Security-Policy.

Special 🙏 and 🤘 and ❤️ to:

Recommended Resolution

This vulnerability is fixed in the latest versions of Zammad and it is recommended to upgrade to one of these.

Fixed releases can be found at:

Additional information

Online version of this advisory: https://zammad.com/en/advisories/zaa-2021-16

Send all remarks to security issues to security@zammad.com.

Signup
Freuen Ihre Kunden sich schon auf die Service-Hotline?
Kostenlos testen!
Newsletter
Alle Neuigkeiten direkt in Ihrer Inbox!
Zum Newsletter anmelden