Security Advisory

ZAA-2022-10

· Please read carefully and check if the version of your Zammad system is affected by this vulnerability. Please send us information regarding vulnerabilities in Zammad!

Security Advisory Details

  • ID: ZAA-2022-10
  • Date: 09/13/2022
  • Title: Incorrect Access Control
  • Severity: medium
  • Product: Zammad 5.2.x
  • Fixed in: Zammad 5.2.2
  • References:
    --> CVE-2022-40817

Vulnerability Descriptions

Incorrect Access Control

Zammad has a fine-grained permission model that allows to configure read-only access to tickets. However, agents were still wrongly able to perform some operations on such tickets, like adding and removing links, tags and related answers.

Recommended Resolution

This vulnerability is fixed in the latest versions of Zammad and it is recommended to upgrade to one of these.

Fixed releases can be found at:

Or just update your Zammad if installed via OS package manager.

Additional information

Online version of this advisory: https://zammad.com/en/advisories/zaa-2022-10

Please send remarks on security issues exclusively to security@zammad.com.

Signup
Freuen Ihre Kunden sich schon auf die Service-Hotline?
Kostenlos testen!
Newsletter
Alle Neuigkeiten direkt in Ihrer Inbox!
Zum Newsletter anmelden