Security Advisory

ZAA-2020-05

· Please read carefully and check if the version of your Zammad system is affected by this vulnerability. Please send us information regarding vulnerabilities in Zammad!

Security Advisory Details

  • ID: ZAA-2020-05
  • Date: 03/03/2020
  • Title: Authorization Issues Allow for Users to View Data from Others
  • Severity: high
  • Product: Zammad 1.0.x up to 3.2.0
  • Fixed in: Zammad 3.2.1, 3.3.0
  • References:
    --> CVE: 2020-10100

Vulnerability Descriptions

Authorization Issues Allow for Users to View Data from Others (CVE 2020-10100)

Zammad allows for users to view ticket customer details associated with specific customers. However, the application does not properly implement access controls related to this functionality. As such, users of one company are able to access ticket data from other companies.

Due to the multi-tenant nature of this application, users who can access ticket details from one organization to the next allows for users to ex-filtrate potentially sensitive data of other companies.

Special 🙏 and 🤘 and ❤️ to:

Recommended Resolution

This vulnerability is fixed in the latest versions of Zammad and it is recommended to upgrade to one of these.

Fixed releases can be found at:

Additional information

Online version of this advisory: https://zammad.com/en/advisories/zaa-2020-05

Send all remarks to security issues to security@zammad.com.

Signup
Freuen Ihre Kunden sich schon auf die Service-Hotline?
Kostenlos testen!
Newsletter
Alle Neuigkeiten direkt in Ihrer Inbox!
Zum Newsletter anmelden